Issues affecting quickpageapp.com application
Incident Report for Quickpage
Resolved
Quickpage is back up, and we’re continuing work to keep it stable. We’re so sorry for the downtime today.
Posted Jul 15, 2020 - 22:04 UTC
Identified
We are currently experiencing an outage affecting all apps. We apologize for the inconvenience. Our data layer on https://compose.com is experiencing the issues. https://status.compose.com. Will update when we are back.
Posted Jul 15, 2020 - 15:57 UTC
This incident affected: Quickpage.